you are running composer with SSL/TLS protected disabled

composer require houdunwang/cart

当尝试运以上命令时候;

却出现了报错提示

[Composer\Exception\NoSslException]

The openssl extension is required for SSL/TLS protection but is not available. 

If you can not enable the openssl extension,

you can disable this error, at your own risk, 

by setting the 'disable-tls' option to true

然后,尝试开启php.ini中openssl扩展

extension=php_openssl.dll

这个时又提示

you are  running composer with SSL/TLS protected disabled

这时需要运行:

composer config -g -- disable-tls true

然后重启服务器环境

再重新运行composer

问题得到解决

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动。

武斌博客 http://www.wubin.pro

Top